Warning: ob_start(): function 'compress_handler' not found or invalid function name in /www/htdocs/xfmantis/core.php on line 18
0001999: Weapon replace issue : lost ammo - Mantis
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001999 [X-Force] Allgemein tweak always 15.08.08 07:45 18.09.08 03:00
Reporter gnfalex View Status public  
Assigned To Jim_Raynor
Priority normal Resolution fixed  
Status closed   Product Version V0.912
Summary 0001999: Weapon replace issue : lost ammo
Description if ammo is researched after weapon, that replace something, it lost (write "weapon non researched yet" and cannot be used ).
If ammo is researched before weapon, that replace something, it assigned normally.
If you want to add ammo to weapon1, that replace weapon0, after weapon1 has been researched, you need to assign ammo as munition for weapon0.

Replace sequence Weapon3>weapon2>weapon1>weapon0 work fine


Shipammo1 is assigned as munition for Shipweapon1.
Shipweapon1 replace Shipweapon0.
If research seqence is "Shipammo1 - Shipweapon1" then as result, exist "Shipweapon1" with munitions "Shipammo1" and "Shipammo2".
If research seqence is "Shipweapon1 - Shipammo1" then as result, exist "Shipweapon1" with munition only "Shipammo0". Shipammo1 is lost ( write "weapon non researched yet").

Weapon1 replace weapon0.
Ammo1_1 and ammo1_2 is munition for weapon1.
Research seqence is "Ammo1_1 - weapon1 - Ammo1_2"
Result:weapon1 with ammo Ammo0 and Ammo1_1. Ammo1_2 is lost
Additional Information
Attached Files  testreplace.pak [^] (4,096 bytes) 15.08.08 07:45

- Relationships

- Notes
15.08.08 12:23

We plan to change the ammo-weapon-coordination to a different method in one of the future versions, that will solve this automatically.

However it looks like that change will be delayed to get other things done first. It has not yet been decided wether or not we will make a temporary fix for this until the method is changed.
17.08.08 08:10

The fix was very small.

- Issue History
Date Modified Username Field Change
15.08.08 07:45 gnfalex New Issue
15.08.08 07:45 gnfalex File Added: testreplace.pak
15.08.08 12:23 DirkF Note Added: 0003509
17.08.08 08:10 Jim_Raynor Status new => resolved
17.08.08 08:10 Jim_Raynor Fixed in Version  => V0.915a04
17.08.08 08:10 Jim_Raynor Resolution open => fixed
17.08.08 08:10 Jim_Raynor Assigned To  => Jim_Raynor
17.08.08 08:10 Jim_Raynor Note Added: 0003513
18.09.08 03:00 Gast Status resolved => closed

Mantis 1.0.7[^]
Copyright © 2000 - 2007 Mantis Group
Powered by Mantis Bugtracker