Warning: ob_start(): function 'compress_handler' not found or invalid function name in /www/htdocs/xfmantis/core.php on line 18
0001615: TUFO.geoscape:Boolean - Ist das UFO dargestellt ja/nein - Mantis
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001615 [X-Force] Raumschiffkampf feature N/A 24.07.07 18:16 15.11.09 03:00
Reporter DirkF View Status public  
Assigned To gnfalex
Priority normal Resolution fixed  
Status closed   Product Version
Summary 0001615: TUFO.geoscape:Boolean - Ist das UFO dargestellt ja/nein
Description Ein Flag mit dem man ein UFO vom Geoscape verschwinden lassen kann, ohne das es gelöscht oder deregistriert wird.

Ob das UFO dann komplett vom Geoscape entfernt ist (d.h. weder Events erhält noch produziert) oder nur unsichtbar (d.h. es produziert keine Events, erhält sie aber) sollte davon abhängig gemacht werden, was einfacher zu programmieren ist
Additional Information Hauptsächlich gedacht für simulierte Landemanöver (verschwunden während Bodeneinsatz, danach wieder angezeigt), kann aber auch für andere Zwecke genutzt werden.
Attached Files  0001615_try1.zip [^] (106,439 bytes) 13.10.09 15:13
 0001615_try2.zip [^] (105,671 bytes) 14.10.09 08:57

- Relationships
duplicate of 0000642closed  X-Skript TUFO-Eigenschaft hidden (getarnt) 

- Notes
28.07.07 21:38

MMh. Das einfachste dürfte wohl sein, dass UFO in einer anderen Liste zwischen zu speichern. Aber muss ich mich näher mit beschäftigen.
13.10.09 15:12

I try some other way:
In 0001615_try1.zip variable 'TUFO.AntiRadarCoat : integer' is added (sorry, I cannot find better name).
Now if AntiradarCoat>0 status Visible for UFO is blocked (and it is become unvisible).
In this state ufo can attack, but cannot be attaked by base or aircraft.
I dont try to forcely target aircraft at hidden ufo, but if hide it during intercept, aircraft return to base.
If set AntiradarCoat to 0 it will again appear on next turn.
Additional effect - base now cannot attack invisible target.

I hope, that this can be used later for 0002056 also (if AntiradarCoat>RadarForce then HideUFO, inScanArea will return RadarForce at this point).

Best regards.
13.10.09 19:24

OK, that'll help, but we have to wait for Natter to see if this can/should be added to the 915B5 or wait for the 917.

The 2056 is partially on-hold because we aren't sure wether that approach is a good one or if we choose another solution (that's one of the reasons why its an internal ticket, visible only inTeam).
14.10.09 08:56

OK, without 2056 it becomes more accurately: 0001615_try2.zip.
PS. To change to TUFO.Geoscape default value must be true. I try 'AntiRadarCoat :Boolean=True;' but it don't work (error during compiling/build). Sorry, how to change default value of variable?
Best regards
14.10.09 11:04


@@ -118,7 +118,7 @@
     else if Objekt is TCustomGameMessageData then
- else if (Objekt is TUFO) or (Objekt is TGround) then
+ else if ((Objekt is TUFO) and TUFO(objekt).Visible) or (Objekt is TGround) then


AntiRadarCoat :Boolean=True; won't work, because in Delphi you can only use this syntax for global variables. You should use TUFO.Create for default values.

But I prefer AntiRadarCoat.
14.10.09 13:08


Sorry, this is error. I add this to when work on imposibility of give order to intercept, then the game message is showed (for example, if invisible ufo take aircraft as target), and later forgot to remove. It may not work (I don't check) because of wrong place and now has no sense because exist checkup in order of aircraft (i.e. order may be given, but aircraft not move from base). Please remove this. Sorry.

Best regards
14.10.09 13:37

Variante 2 wurde umgesetzt.

- Issue History
Date Modified Username Field Change
24.07.07 18:16 DirkF New Issue
25.07.07 01:42 Natter Relationship added duplicate of 0000642
28.07.07 21:38 Jim_Raynor Note Added: 0002579
31.07.07 10:08 Jim_Raynor Relationship added related to 0001534
09.04.08 14:35 Natter Relationship added related to 0001798
09.04.08 14:35 Natter Relationship deleted related to 0001534
04.03.09 12:49 DirkF Relationship added related to 0002056
23.05.09 17:54 DirkF Relationship added related to 0002111
23.05.09 17:54 DirkF Relationship deleted related to 0001798
13.10.09 15:12 gnfalex Note Added: 0004277
13.10.09 15:13 gnfalex File Added: 0001615_try1.zip
13.10.09 19:24 DirkF Note Added: 0004278
13.10.09 19:25 DirkF Status new => assigned
13.10.09 19:25 DirkF Assigned To  => gnfalex
14.10.09 08:56 gnfalex Note Added: 0004279
14.10.09 08:57 gnfalex File Added: 0001615_try2.zip
14.10.09 11:04 Natter Note Added: 0004280
14.10.09 13:08 gnfalex Note Added: 0004281
14.10.09 13:37 Natter Status assigned => resolved
14.10.09 13:37 Natter Fixed in Version  => V0.915b05
14.10.09 13:37 Natter Resolution open => fixed
14.10.09 13:37 Natter Note Added: 0004282
16.10.09 14:54 Natter Relationship deleted related to 0002111
15.11.09 03:00 Gast Status resolved => closed

Mantis 1.0.7[^]
Copyright © 2000 - 2007 Mantis Group
Powered by Mantis Bugtracker